摘要:WordPress 5.2 正式版发布后,要求PHP版本最低为 PHP 5.6.20,而老薜主机的版本当前是 5.6,软件总是推动着硬件在升级,我们该如何升级老薜主机的PHP版本呢?

今天在将一个用 WordPress 程序搭建的网站搬迁到老薛主机后,网站后台提示“需要更新PHP”:WordPress 检测到您正在运行不安全的PHP版本。

WordPress 5.2 正式版发布后,要求PHP版本最低为 PHP 5.6.20,目前 PHP 最新版本已更新到7.3了。软件总是推动着硬件在升级,我们该如何升级老薜主机的PHP版本呢?

其实用户自己就可以办到,请跟着我一步一步来操作:

1、登录老薜主机,在用户中心,登录 cPanel 面板;

2、在 cPanel 主页,下拉到“软件”模块,点击“Select PHP Version”;

3、在 PHP version 右侧的下拉菜单中选择你需要的版本号,如我选了最高的 7.3 版。

界面中会出现扩展选项,我们默认即可,你还可以点击右上角的“Switch to PHP options”按钮,设置 PHP 选项,不是特别精通的,建议你默认为好。

4、记得点击一次“Set as current”,这样才会保存你选择的 PHP 版本。

返回网站后台,刷新查看,原来的“需要更新PHP”提示已经消失,老薜主机的 PHP 版本顺利升级完成。

新版本的 PHP 总会带来一起新功能,也有利于提高网站的运行速度,当然,要注意排查下你使用的主题或插件有没有 PHP 版本限制。

历史上的今天: