摘要:今天我遇到的是因网站空间配置不高所导致的程序升级受限的问题:您无法更新,因为WordPress 5.2.1需要PHP 5.6.20或更高版本。

大家总有这样的体验,伴随着微软 Windows 操作系统的产品更迭,计算机的硬件也是不断更新升级,不然的话,用户体验就会非常差,比如打开慢,容易卡,会死机等。

许多的软件更新也有这样的情况,随着新版本的更新,加入了新的技术支持,而这些新技术多数是要由新的硬件支撑的,所以新版本在旧的操作系统下就会不可用,在配置差的机子上就不能运行。

软件和硬件,就像一个人的两条脚,相互扶持又互为羁绊,彼此同步时最流畅,效果也最好,任何一方拖了后脚,都会影响用户的使用体验。

今天我遇到的,是因网站空间配置不高所导致的,程序升级受限的问题。

网站是采用世界最流行的博客程序 WordPress 架构的,它的操作性、扩展性、稳定性都非常好,上手容易,资源丰富,是当前许多站长建站的首选。

而 WordPress 另一个特色,就是更新升级频繁,及时修正安全漏洞,经常推出新酷功能。不过,WordPress 的升级非常方便,一般只需在后台点击“立即更新”按钮即可静默更新,无须人工过多手动干预。这也是我选择它的一个重要原因,懒人的福音。

最近 WordPress 更新到了 5.2.1 版本,当我习惯性地点击更新,准备升级时,系统却提示:You cannot update because WordPress 5.2.1 requires PHP version 5.6.20 or higher. You are running version 5.5.30.(您无法更新,因为WordPress 5.2.1需要PHP 5.6.20或更高版本。 您正在运行版本5.5.30。)

网站空间用的是阿里云的虚拟主机,客服说 PHP 版本可以在主机管理平台上自行更换的。我仔细看了下空间的配置,PHP5.2-5.5,原来它支持的 PHP 最高版本是5.5 。

这就比较尴尬了,我又询问了下客服,得到的答复是:万网的虚拟主机PHP最高版本只有5.5,没有办法调整,如果要更高版本的,只能是用服务器。

PHP 现在的最新版本已经到 7.2 了,许多软件在升级时也是积极应用了新版本中的新技术,就像 WordPress 一样,它支持的最低版本是5.6.20 ,我们的硬件厂商也要积极跟上步伐啊。

是继续使用当前的空间,维护目前的版本,还是更换空间,升级到最新版本,对于有升级强迫症的我来说,是种纠结。看看当前这个空间还有半年的使用期限,还是忍一忍吧,到期后再更换到阿里云服务器上,享受 WordPress 的用户新体验。

历史上的今天: